dpkg erro r обработка linux -image afte r обновление с 16.04 до 18.04 - proUbuntu
1 голос
/ 21 августа 2020

Я только что обновился до Ubuntu MATE 18.04 с 16.04. Были некоторые препятствия, которые я опоздал r описал ниже, но сейчас обновление "завершено", за исключением fo r следующего набора ошибок, когда dpkg настраивает пакеты, что приводит к сбою при попытке обновить что-либо.

Bus error (core dumped)
dpkg: error processing package linux-image-4.15.0-112-generic (--configure):
 installed linux-image-4.15.0-112-generic package post-installation script subprocess returned error exit status 135
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-4.15.0-112-generic; however:
  Package linux-image-4.15.0-112-generic is not configured yet.

dpkg: error processing package linux-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-modules-extra-4.15.0-112-generic:
 linux-modules-extra-4.15.0-112-generic depends on linux-image-4.15.0-112-generic | linux-image-unsigned-4.15.0-112-generic; however:
  Package linux-image-4.15.0-112-generic is not configured yet.
  Package linux-image-unsigned-4.15.0-112-generic is not installed.

dpkg: error processing package linux-modules-extra-4.15.0-112-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 4.15.0.112.100); however:
  Package linux-image-generic is not configured yet.

dpkg: error processing package linux-generic (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-4.15.0-112-generic
 linux-image-generic
 linux-modules-extra-4.15.0-112-generic
 linux-generic

Я пробовал apt-get install -f, apt-get clean, apt-get autoremove и dpkg --configure -a, но он все еще не работает. Я не пробовал очищать и переустанавливать эти пакеты вручную в случае сбоя загрузки, потому что эти пакеты выглядят очень важными.

Как для r хронология:

  1. Сначала запустил do-release-upgrade на работе, но я довольно рано остановил загрузку, потому что Inte rnet нестабилен.
  2. Я заметил, что мой Apache не работает должным образом, поэтому я снова попробовал do-release-upgrade . Я получил предупреждение о том, что мне нужно перейти на последний патч, и я обнаружил, что он «обновлен» с примерно 1500 пакетами, «сохраненными».
  3. После r небольшого просмотра, я запустил apt-get install -f. Он загрузил около 650 МБ пакетов, и после того, как я перезапустил r, ОС запустилась, но со сломанным GUI, который выглядит как Windows 98.
  4. Я запустил apt-get dist-upgrade, и он загрузил около 1,5 ГБ пакетов. После того, как r закончил, я перезагрузился, и ОС работает "нормально", за исключением ошибок, указанных выше. Хотя Apache по-прежнему не работает должным образом.

Извините, если я нарушил какое-либо правило. Это мой первый пост. Я был бы очень признателен за r за любую помощь от этого сообщества. Прямо сейчас я делаю резервную копию важных файлов на случай, если мне придется переустанавливать Linux, но я действительно надеюсь, что смогу продолжить работу с этим. Спасибо за r чтение.

Редактировать: Запуск uname -r показывает 4.4.0-187-generic.

Редактировать 2: Я также очистил старые r ядра. Та же ошибка r все еще происходит.

...