utserve r: /lib/x86_64-linux-gnu/libcrypto.so.1.0.0: версия `OPENSSL_1.0.0 'не найдена (требуется для utserve r) - proUbuntu
0 голосов
/ 20 августа

Я пытался установить торрент на свой ubuntu 20.04.1 LTS. Сначала я загрузил файл ta r с официального сайта торрента ссылка Я выбрал этот µTorrent Server for Ubuntu 13.04 И я просмотрел видео ссылка И я ввел следующую команду:

cd Downloads
sudo tar -xvzf utserver.tar.gz -C /opt/
sudo chmod -R 755 /opt/utorrent-server-alpha-v3_3/
sudo ln -s /opt/utorrent-server-alpha-v3_3/utorrent /usr/bin/utorrent

И когда я выполнил utorrent -settingspath /opt/utorrent-server-alpha-v3_3/, я получил ошибку r

utserver: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

Затем я попробовал sudo apt-get install libssl1.0.0 libssl-dev Затем я получил

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libssl1.0.0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Затем я искал и обнаружил, что libssl1.0.1 не является длинным r доступным для r ubuntu 18.0 и более поздним r. Итак, я попробовал sudo apt install libssl1.1

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libssl1.1 is already the newest version (1.1.1f-1ubuntu2).
libssl1.1 set to manually installed.
The following packages were automatically installed and are no longer required:
  libfprint-2-tod1 libllvm9 libllvm9:i386
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Но опять же я столкнулся с той же ошибкой r, затем я попробовал это решение ссылка Затем я выполняю

cd /lib/x86_64-linux-gnu/
sudo ln -s libssl.so.1.1 libssl.so.1.0.0
sudo ln -s libcrypto.so.1.1 libcrypto.so.1.0.0

И когда я выполняю utserver -settingspath /opt/utorrent-server-alpha-v3_3/, я получаю

utserver: /lib/x86_64-linux-gnu/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by utserver)
utserver: /lib/x86_64-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by utserver)

Я новичок в ubuntu, пожалуйста, предположите, сделал ли я что-то здесь не так.

...