Зависание в процессе обновления и обновления, даже если не удается установить другие r пакетов - proUbuntu
0 голосов
/ 31 июля 2020

Я застреваю при обновлении и обновлении. Я использую Ubuntu 16.04. Когда я использую команду для обновления и обновления.

sudo apt install -f && apt update && apt upgrade

Erro r afte r выполнение команды

Когда я поискал в Google эту ошибку r, какой-то комментарий предлагал запустить эту команду.

dpkg --configure -a

Я получил еще r erro r после r выполнение.

dpkg: dependency problems prevent configuration of systemd-shim:   
 systemd-shim depends on cgmanager (>= 0.32); however:  
  Package cgmanager is not installed.

dpkg: error processing package systemd-shim (--configure):  
 dependency problems - leaving unconfigured   
dpkg: dependency problems prevent configuration of libpam-systemd:amd64:   
 libpam-systemd:amd64 depends on systemd-shim (>= 8-2) | systemd-sysv; however:  
  Package systemd-shim is not configured yet. 
  Package systemd-sysv is not installed.

dpkg: error processing package libpam-systemd:amd64 (--configure):
 dependency problems - leaving unconfigured 
dpkg: dependency problems prevent configuration of policykit-1: 
 policykit-1 depends on libpam-systemd; however: 
  Package libpam-systemd:amd64 is not configured yet.

dpkg: error processing package policykit-1 (--configure):  
 dependency problems - leaving unconfigured   
dpkg: dependency problems prevent configuration of colord:  
 colord depends on policykit-1 (>= 0.103); however: 
  Package policykit-1 is not configured yet.

dpkg: error processing package colord (--configure):  
 dependency problems - leaving unconfigured 
Errors were encountered while processing: 
 systemd-shim 
 libpam-systemd:amd64 
 policykit-1 
 colord

Другое r действие, которое я выполняю fo r, то есть я пытаюсь переустановить пакет, используя

sudo apt install --reinstall colord

Ошибка r wa снова такая же, как на рис.1.

Когда я пытаюсь удалить. deb и загрузите на официальном сайте, я установил его:

dpkg -i cgmanager_0.39-2ubuntu5_amd64.deb

Он все еще не может завершить sh установку. Я использую root для входа. Я застрял с этой проблемой на r несколько дней.

...