Версия GEGL слишком старая erro r? - proUbuntu
1 голос
/ 29 мая

Я получаю слишком старую версию GEGL erro r whl ie открытие GIMP после r обновление до Ubuntu 20.04. Полная ошибка r:

GEGL version too old!

GIMP requires GEGL version 0.4.22 or later.
Installed GEGL version is 0.4.18.

Somehow you or your software packager managed
to install GIMP with an older GEGL version.

Please upgrade to GEGL version 0.4.22 or later.

Но я проверил свою установленную версию gegl, которая составляет 0.4.22-3.

Я описал здесь, но это не работает

Помогите пожалуйста !!! Я не могу использовать GIMP.

Вот файл /etc/apt/sources.list

# deb cdrom:[Ubuntu 19.10 _Eoan Ermine_ - Release amd64 (20191017)]/ eoan main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://in.archive.ubuntu.com/ubuntu/ focal main restricted universe
# deb-src http://in.archive.ubuntu.com/ubuntu/ eoan main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://in.archive.ubuntu.com/ubuntu/ focal-updates main restricted universe
# deb-src http://in.archive.ubuntu.com/ubuntu/ eoan-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
# deb-src http://in.archive.ubuntu.com/ubuntu/ eoan universe
# deb-src http://in.archive.ubuntu.com/ubuntu/ eoan-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
# deb-src http://in.archive.ubuntu.com/ubuntu/ eoan multiverse
# deb-src http://in.archive.ubuntu.com/ubuntu/ eoan-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://in.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe
# deb-src http://in.archive.ubuntu.com/ubuntu/ eoan-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu eoan partner
# deb-src http://archive.canonical.com/ubuntu eoan partner

deb http://security.ubuntu.com/ubuntu focal-security main restricted universe
# deb-src http://security.ubuntu.com/ubuntu eoan-security main restricted
# deb-src http://security.ubuntu.com/ubuntu eoan-security universe
# deb-src http://security.ubuntu.com/ubuntu eoan-security multiverse

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

Ответы [ 4 ]

4 голосов
/ 27 июля

У меня была такая же проблема на Ubuntu Mate 20.04.

Решил ее следующим образом. Репозиторий otto-kesselgulasch амортизируется и не требует длительного обслуживания r. Его необходимо заменить .

sudo apt install ppa-purge
sudo ppa-purge ppa:otto-kesselgulasch/gimp
sudo add-apt-repository ppa:ubuntuhandbook1/gimp
sudo apt update && sudo apt upgrade

Если это не сработает, вам может потребоваться переустановить GIMP

sudo apt install gimp gimp-gmic

Это сработало для r me.

Вам также может потребоваться выполнить

sudo apt autoremove

и

sudo apt update && sudo apt upgrade

fo r число r циклов, пока не будут выполнены все зависимости и удалены неиспользуемые зависимости.

Попытка установить GEGL не помогла мне r. Я удалил / очистил GIMP (и GEGL 0.4.22 - он был установлен правильно!), Как указано выше, r раз без результата. Однако r, выполнение этой процедуры с самого начала сработало в первый раз на моей второй машине!

Благодаря Ubuntu Handbook fo r, на котором размещен репозиторий.

2 голосов
/ 05 июня

У меня была такая же проблема, решенная удалением Otto PPA:

sudo apt install ppa-purge -y
sudo ppa-purge ppa:otto-kesselgulasch/gimp

Он сообщит вам, что для некоторых пакетов требуется более ранняя версия, accept et voila '

(я исходил из 19.10 обновлено до 20.04)

0 голосов
/ 24 июля

У меня была такая же проблема. Вы можете решить эту проблему, удалив gimp с помощью

sudo apt remove --auto-remove gimp

. Это также удалит оставшиеся r зависимости пакетов gimp и, следовательно, все версии зависимостей libgegl и olde r .

, а затем переустановите gimp с помощью

sudo apt install gimp

Это установит последние версии необходимых зависимостей fo r gimp.

0 голосов
/ 23 июля

Вы можете просто попробовать:

sudo apt-get install gegl
...