20.04. Звук. Звук перестал работать на Bluetooth-гарнитуре HD 4.40BT unde r Профиль головного устройства гарнитуры - proUbuntu
1 голос
/ 09 июля 2020

все! Я использую Ubuntu 20.04 на ноутбуке с помощью bluetooth-гарнитуры. Внутренний mi c работает нормально. Другой профиль r Hi Fi работает нормально, но когда я переключаю профиль на HSP / HFP, звука нет.

Он работал до недавнего обновления. Пытался перезагрузиться с предыдущей версией ядра, но не помогло.

Устройство доступно в настройках.

В pavucontrol все равно. Он присутствует, но звука нет.

Вывод карт списка pactl

Card #0
    Name: alsa_card.pci-0000_00_1f.3-platform-skl_hda_dsp_generic
    Driver: module-alsa-card.c
    Owner Module: 7
    Properties:
        alsa.card = "0"
        alsa.card_name = "sof-hda-dsp"
        alsa.long_card_name = "HP-HPSpectrex360Convertible13_ap0xxx--8514"
        alsa.driver_name = "snd_soc_skl_hda_dsp"
        device.bus_path = "pci-0000:00:1f.3-platform-skl_hda_dsp_generic"
        sysfs.path = "/devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "9dc8"
        device.product.name = "Cannon Point-LP High Definition Audio Controller"
        device.string = "0"
        device.description = "Cannon Point-LP High Definition Audio Controller"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    Profiles:
        HiFi: Play HiFi quality Music (sinks: 4, sources: 2, priority: 8000, available: yes)
        off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
    Active Profile: HiFi
    Ports:
        [Out] HDMI3: HDMI3/DP3 Output (priority: 700, latency offset: 0 usec, not available)
            Part of profile(s): HiFi
        [Out] HDMI2: HDMI2/DP2 Output (priority: 600, latency offset: 0 usec, available)
            Properties:
                device.product.name = "SAMSUNG"
            Part of profile(s): HiFi
        [Out] HDMI1: HDMI1/DP1 Output (priority: 500, latency offset: 0 usec, not available)
            Part of profile(s): HiFi
        [Out] Speaker: Speaker (priority: 100, latency offset: 0 usec)
            Part of profile(s): HiFi
        [Out] Headphones: Headphones (priority: 200, latency offset: 0 usec, not available)
            Part of profile(s): HiFi
        [In] Mic2: Headphones Stereo Microphone (priority: 200, latency offset: 0 usec, not available)
            Part of profile(s): HiFi
        [In] Mic1: Digital Microphone (priority: 100, latency offset: 0 usec)
            Part of profile(s): HiFi

Card #1
    Name: bluez_card.00_16_94_31_38_AB
    Driver: module-bluez5-device.c
    Owner Module: 26
    Properties:
        device.description = "HD 4.40BT"
        device.string = "00:16:94:31:38:AB"
        device.api = "bluez"
        device.class = "sound"
        device.bus = "bluetooth"
        device.form_factor = "headset"
        bluez.path = "/org/bluez/hci0/dev_00_16_94_31_38_AB"
        bluez.class = "0x240404"
        bluez.alias = "HD 4.40BT"
        device.icon_name = "audio-headset-bluetooth"
        device.intended_roles = "phone"
    Profiles:
        headset_head_unit: Headset Head Unit (HSP/HFP) (sinks: 1, sources: 1, priority: 30, available: yes)
        a2dp_sink: High Fidelity Playback (A2DP Sink) (sinks: 1, sources: 0, priority: 40, available: yes)
        off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
    Active Profile: headset_head_unit
    Ports:
        headset-output: Headset (priority: 0, latency offset: 0 usec, available)
            Part of profile(s): headset_head_unit, a2dp_sink
        headset-input: Headset (priority: 0, latency offset: 0 usec, available)
            Part of profile(s): headset_head_unit

Как найти причину root?

Выдержка из истории apt .log

Commandline: aptdaemon role='role-commit-packages' sender=':1.113'
Install: libllvm10:amd64 (1:10.0.0-4ubuntu1, automatic)
Upgrade: libreoffice-style-breeze:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), evince:amd64 (3.36.0-2, 3.36.5-0ubuntu1), libreoffice-math:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), evolution-data-server-common:amd64 (3.36.2-0ubuntu1, 3.36.3-0ubuntu1), gnome-calendar:amd64 (3.36.1-1, 3.36.2-0ubuntu1), libgphoto2-port12:amd64 (2.5.24-1, 2.5.25-0ubuntu0.1), uno-libs-private:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libvte-2.91-0:amd64 (0.60.1-1ubuntu1, 0.60.3-0ubuntu1~20.04), libedataserverui-1.2-2:amd64 (3.36.2-0ubuntu1, 3.36.3-0ubuntu1), gir1.2-gtk-3.0:amd64 (3.24.18-1ubuntu1, 3.24.20-0ubuntu1), gir1.2-mutter-6:amd64 (3.36.2-1ubuntu1~20.04.1, 3.36.3-0ubuntu0.20.04.1), libridl-java:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libevdocument3-4:amd64 (3.36.0-2, 3.36.5-0ubuntu1), libuno-salhelpergcc3-3:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), thunderbird-locale-es-ar:amd64 (1:68.8.0+build2-0ubuntu0.20.04.2, 1:68.10.0+build1-0ubuntu0.20.04.1), python3-software-properties:amd64 (0.98.9, 0.98.9.1), thunderbird-locale-es-es:amd64 (1:68.8.0+build2-0ubuntu0.20.04.2, 1:68.10.0+build1-0ubuntu0.20.04.1), libgphoto2-6:amd64 (2.5.24-1, 2.5.25-0ubuntu0.1), libegl-mesa0:amd64 (20.0.4-2ubuntu1, 20.0.8-0ubuntu1~20.04.1), libreoffice-gtk3:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), shotwell-common:amd64 (0.30.8-0ubuntu2, 0.30.10-0ubuntu0.1), libgtk-3-common:amd64 (3.24.18-1ubuntu1, 3.24.20-0ubuntu1), libjuh-java:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libgtk-3-0:amd64 (3.24.18-1ubuntu1, 3.24.20-0ubuntu1), libreoffice-core:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libedata-cal-2.0-1:amd64 (3.36.2-0ubuntu1, 3.36.3-0ubuntu1), libglapi-mesa:amd64 (20.0.4-2ubuntu1, 20.0.8-0ubuntu1~20.04.1), libasound2-data:amd64 (1.2.2-2.1, 1.2.2-2.1ubuntu1), snapd:amd64 (2.44.3+20.04, 2.45.1+20.04), libreoffice-l10n-en-gb:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libreoffice-l10n-en-za:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libgphoto2-l10n:amd64 (2.5.24-1, 2.5.25-0ubuntu0.1), libxatracker2:amd64 (20.0.4-2ubuntu1, 20.0.8-0ubuntu1~20.04.1), gnutls-bin:amd64 (3.6.13-2ubuntu1.1, 3.6.13-2ubuntu1.2), libegl1-mesa:amd64 (20.0.4-2ubuntu1, 20.0.8-0ubuntu1~20.04.1), evolution-data-server:amd64 (3.36.2-0ubuntu1, 3.36.3-0ubuntu1), passwd:amd64 (1:4.8.1-1ubuntu5, 1:4.8.1-1ubuntu5.20.04), libreoffice-l10n-de:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libreoffice-l10n-es:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libreoffice-l10n-ru:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), nautilus-extension-gnome-terminal:amd64 (3.36.1.1-1ubuntu1, 3.36.2-1ubuntu1~20.04), libmutter-6-0:amd64 (3.36.2-1ubuntu1~20.04.1, 3.36.3-0ubuntu0.20.04.1), software-properties-gtk:amd64 (0.98.9, 0.98.9.1), python3-uno:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libuno-cppuhelpergcc3-3:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libgbm1:amd64 (20.0.4-2ubuntu1, 20.0.8-0ubuntu1~20.04.1), mutter-common:amd64 (3.36.2-1ubuntu1~20.04.1, 3.36.3-0ubuntu0.20.04.1), thunderbird-gnome-support:amd64 (1:68.8.0+build2-0ubuntu0.20.04.2, 1:68.10.0+build1-0ubuntu0.20.04.1), deja-dup:amd64 (40.6-1ubuntu2, 40.7-0ubuntu1), libreoffice-base-core:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libreoffice-ogltrans:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libebackend-1.2-10:amd64 (3.36.2-0ubuntu1, 3.36.3-0ubuntu1), libuno-purpenvhelpergcc3-3:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libreoffice-impress:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), evince-common:amd64 (3.36.0-2, 3.36.5-0ubuntu1), libreoffice-style-elementary:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libgtk-3-bin:amd64 (3.24.18-1ubuntu1, 3.24.20-0ubuntu1), libebook-1.2-20:amd64 (3.36.2-0ubuntu1, 3.36.3-0ubuntu1), libreoffice-help-de:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libreoffice-help-es:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), gir1.2-vte-2.91:amd64 (0.60.1-1ubuntu1, 0.60.3-0ubuntu1~20.04), libreoffice-help-ru:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libevview3-3:amd64 (3.36.0-2, 3.36.5-0ubuntu1), libjurt-java:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libreoffice-help-common:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), thunderbird-locale-en-gb:amd64 (1:68.8.0+build2-0ubuntu0.20.04.2, 1:68.10.0+build1-0ubuntu0.20.04.1), thunderbird-locale-en-us:amd64 (1:68.8.0+build2-0ubuntu0.20.04.2, 1:68.10.0+build1-0ubuntu0.20.04.1), libreoffice-style-colibre:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), ure:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libreoffice-writer:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libgail-3-0:amd64 (3.24.18-1ubuntu1, 3.24.20-0ubuntu1), libreoffice-common:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), wpasupplicant:amd64 (2:2.9-1ubuntu4, 2:2.9-1ubuntu4.1), shotwell:amd64 (0.30.8-0ubuntu2, 0.30.10-0ubuntu0.1), login:amd64 (1:4.8.1-1ubuntu5, 1:4.8.1-1ubuntu5.20.04), libgl1-mesa-dri:amd64 (20.0.4-2ubuntu1, 20.0.8-0ubuntu1~20.04.1), thunderbird:amd64 (1:68.8.0+build2-0ubuntu0.20.04.2, 1:68.10.0+build1-0ubuntu0.20.04.1), libasound2:amd64 (1.2.2-2.1, 1.2.2-2.1ubuntu1), libuno-cppu3:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), thermald:amd64 (1.9.1-1ubuntu0.1, 1.9.1-1ubuntu0.2), libgl1-mesa-glx:amd64 (20.0.4-2ubuntu1, 20.0.8-0ubuntu1~20.04.1), libvte-2.91-common:amd64 (0.60.1-1ubuntu1, 0.60.3-0ubuntu1~20.04), fonts-opensymbol:amd64 (2:102.11+LibO6.4.3-0ubuntu0.20.04.1, 2:102.11+LibO6.4.4-0ubuntu0.20.04.1), libebook-contacts-1.2-3:amd64 (3.36.2-0ubuntu1, 3.36.3-0ubuntu1), gnome-terminal-data:amd64 (3.36.1.1-1ubuntu1, 3.36.2-1ubuntu1~20.04), libgnutls30:amd64 (3.6.13-2ubuntu1.1, 3.6.13-2ubuntu1.2), libedata-book-1.2-26:amd64 (3.36.2-0ubuntu1, 3.36.3-0ubuntu1), libreoffice-pdfimport:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libecal-2.0-1:amd64 (3.36.2-0ubuntu1, 3.36.3-0ubuntu1), libreoffice-style-tango:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), gtk-update-icon-cache:amd64 (3.24.18-1ubuntu1, 3.24.20-0ubuntu1), libuno-sal3:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), mesa-vdpau-drivers:amd64 (20.0.4-2ubuntu1, 20.0.8-0ubuntu1~20.04.1), linux-firmware:amd64 (1.187, 1.187.1), mesa-vulkan-drivers:amd64 (20.0.4-2ubuntu1, 20.0.8-0ubuntu1~20.04.1), libreoffice-help-en-gb:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libreoffice-help-en-us:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libreoffice-gnome:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libcamel-1.2-62:amd64 (3.36.2-0ubuntu1, 3.36.3-0ubuntu1), libunoloader-java:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), libgnutls-dane0:amd64 (3.6.13-2ubuntu1.1, 3.6.13-2ubuntu1.2), libreoffice-calc:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), gnome-terminal:amd64 (3.36.1.1-1ubuntu1, 3.36.2-1ubuntu1~20.04), thunderbird-locale-de:amd64 (1:68.8.0+build2-0ubuntu0.20.04.2, 1:68.10.0+build1-0ubuntu0.20.04.1), thunderbird-locale-en:amd64 (1:68.8.0+build2-0ubuntu0.20.04.2, 1:68.10.0+build1-0ubuntu0.20.04.1), thunderbird-locale-es:amd64 (1:68.8.0+build2-0ubuntu0.20.04.2, 1:68.10.0+build1-0ubuntu0.20.04.1), thunderbird-locale-ru:amd64 (1:68.8.0+build2-0ubuntu0.20.04.2, 1:68.10.0+build1-0ubuntu0.20.04.1), libedataserver-1.2-24:amd64 (3.36.2-0ubuntu1, 3.36.3-0ubuntu1), libatopology2:amd64 (1.2.2-2.1, 1.2.2-2.1ubuntu1), libreoffice-draw:amd64 (1:6.4.3-0ubuntu0.20.04.1, 1:6.4.4-0ubuntu0.20.04.1), mutter:amd64 (3.36.2-1ubuntu1~20.04.1, 3.36.3-0ubuntu0.20.04.1), mesa-va-drivers:amd64 (20.0.4-2ubuntu1, 20.0.8-0ubuntu1~20.04.1), libglx-mesa0:amd64 (20.0.4-2ubuntu1, 20.0.8-0ubuntu1~20.04.1), software-properties-common:amd64 (0.98.9, 0.98.9.1)
End-Date: 2020-07-09  11:07:45```
...