Сломанный пакет Мариадба - proUbuntu
0 голосов
/ 01 июля 2020

Я застрял и больше не знаю, что делать. Я пытаюсь установить Mariadb, а затем r в каком-то случае эти ошибки сохраняются, как клей.

dpkg: regarding .../mariadb-client-core-10.3_1%3a10.3.23+maria~focal_amd64.deb containing mariadb-client-core-10.3:  mariadb-client-10.3 conflicts with mysql-client-core-5.5   mariadb-client-core-10.3 provides mysql-client-core-5.5 and is to be installed.

dpkg: error processing archive
/var/cache/apt/archives/mariadb-client-core-10.3_1%3a10.3.23+maria~focal_amd64.deb
(--unpack):  conflicting packages - not installing
mariadb-client-core-10.3

dpkg: regarding
.../mariadb-client-10.3_1%3a10.3.23+maria~focal_amd64.deb containing
mariadb-client-10.3:  mariadb-client-core-10.3 conflicts with
mysql-client-5.5   mariadb-client-10.3 provides mysql-client-5.5 and
is to be installed.

dpkg: error processing archive
/var/cache/apt/archives/mariadb-client-10.3_1%3a10.3.23+maria~focal_amd64.deb
(--unpack):  conflicting packages - not installing mariadb-client-10.3

Preparing to unpack .../mysql-common_1%3a10.3.23+maria~focal_all.deb
... Unpacking mysql-common (1:10.3.23+maria~focal) over
(5.8+1.0.5ubuntu2) ... Errors were encountered while processing: 
/var/cache/apt/archives/mariadb-client-core-10.3_1%3a10.3.23+maria~focal_amd64.deb
/var/cache/apt/archives/mariadb-client-10.3_1%3a10.3.23+maria~focal_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Я пробовал эти

sudo apt-get install -f 
sudo apt-get remove --purge mariadb* 
sudo apt-get remove --purge mysql* 
sudo dpkg -i --force-overwrite-all /var/cache/apt/archives/ 
sudo apt-get autoremove

Пожалуйста, помогите мне, поскольку я не могу установить что-нибудь

...