Заставить PHP7.2 работать под Ubuntu 19.10 - proUbuntu
3 голосов
/

Я установил Ubuntu 19.10 и использую его для веб-разработки, в основном с PHP-фреймворками.

У нас есть несколько проектов, которые работают на php7.2 и php7.3. Я установил 7.3, но 7.2 не существует?

Я добавил PPA ppa:ondrej/php, который дал мне php7.3, однако установка php7.2 выдает ошибку

$ sudo apt update

Hit:1 http://linux.teamviewer.com/deb stable InRelease
Hit:2 https://dl.yarnpkg.com/debian stable InRelease                                                                                                                                                                      
Hit:3 http://ca.archive.ubuntu.com/ubuntu eoan InRelease                                                                                                                                                                  
Ign:4 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                      
Hit:5 http://dl.google.com/linux/chrome/deb stable Release                                                                                                                        
Hit:6 http://security.ubuntu.com/ubuntu eoan-security InRelease                                    
Hit:7 http://ca.archive.ubuntu.com/ubuntu eoan-updates InRelease    
Hit:8 http://ppa.launchpad.net/cappelikan/ppa/ubuntu eoan InRelease          
Hit:9 http://ca.archive.ubuntu.com/ubuntu eoan-backports InRelease                                      
Get:11 http://ppa.launchpad.net/ondrej/php/ubuntu eoan InRelease [20.8 kB]                              
Hit:12 http://ppa.launchpad.net/teejee2008/ppa/ubuntu eoan InRelease
Fetched 20.8 kB in 3s (8,105 B/s)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
$ sudo apt install -y php7.2 php7.2-cli

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'php7.2-sodium' for regex 'php7.2'
Note, selecting 'php7.2-thrift' for regex 'php7.2'
E: Unable to locate package php7.2-cli
E: Couldn't find any package by glob 'php7.2-cli'
E: Couldn't find any package by regex 'php7.2-cli'

Кто-нибудь смог установить 7.2 на Ubuntu 19.10, или мне не повезло?

...