Сканер Panasonic не работает на Ubuntu 19.04 - proUbuntu
0 голосов
/

У меня есть многофункциональный лазерный принтер / сканер Panasonic KX-MB 1500. Это работало отлично до Ubuntu 16.04. С тех пор (включая 19.04) работает только принтер, а не сканер.

Panasonic предоставляет драйверы для Ubuntu и Redhat здесь: http://panasonic.net/pcc/support/fax/common/table/linuxdriver.html

После установки драйвера сканера никакой интерфейс не может видеть сканер. Вот вывод команды lsusb & sane-find-scanner. Запуск sane-find-scanner или scanImage -L в качестве sudo не имеет значения.

$ lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
Bus 003 Device 002: ID 0461:4e22 Primax Electronics, Ltd 
**Bus 003 Device 006: ID 04da:0f0b Panasonic (Matsushita)** 
Bus 003 Device 004: ID 04d9:1203 Holtek Semiconductor, Inc. Keyboard
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
$ sudo sane-find-scanner 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

could not fetch string descriptor: Input/output error
could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

1 Ответ

0 голосов
/

Спасибо за ваше предложение, Хейннема. Мне пришлось установить libusb-0.1-4, и тогда все работало как шарм 19.04. Скорее всего, это будет работать и на более ранних версиях. Я не нашел никаких следов этой отсутствующей библиотеки в / var / log / syslog.

Спасибо!

...