Ошибка при установке Firefox Developer Edition на 18.04.1 LTS - proUbuntu
2 голосов
/

Итак, у меня на Ubuntu 18.04.1 LTS установлен обычный Firefox Quantum65.0 Я хочу установить версию для разработчиков Firefox.

Я уже пробовал:

sudo add-apt-repository ppa:ubuntu-mozilla-daily/firefox-aurora
sudo apt-get update
sudo apt-get install firefox

Но он просто переустанавливает обычный Firefox. Итак, я попробовал:

sudo add-apt-repository ppa:ubuntu-desktop/ubuntu-make
sudo apt-get update
sudo apt-get install ubuntu-make

И когда я бегу umake web firefox-dev я получаю Choose installation path: /home/me/.local/share/umake/web/firefox-dev И когда я нажимаю Enter, я получаю следующую ошибку:

ERROR: One default was already registered, can't register a second one in that choices set: ['en-US', 'en-US', 'ach', 'af', 'sq', 'ar', 'an', 'hy-AM', 'as', 'ast', 'az', 'eu', 'be', 'bn-BD', 'bn-IN', 'bs', 'br', 'bg', 'my', 'ca', 'zh-CN', 'zh-TW', 'hr', 'cs', 'da', 'nl', 'en-GB', 'en-CA', 'en-ZA', 'en-US', 'eo', 'et', 'fi', 'fr', 'fy-NL', 'ff', 'gd', 'gl', 'ka', 'de', 'el', 'gn', 'gu-IN', 'he', 'hi-IN', 'hu', 'is', 'id', 'ia', 'ga-IE', 'it', 'ja', 'kab', 'kn', 'cak', 'kk', 'km', 'ko', 'lv', 'lij', 'lt', 'dsb', 'mk', 'mai', 'ms', 'ml', 'mr', 'ne-NP', 'nb-NO', 'nn-NO', 'oc', 'or', 'fa', 'pl', 'pt-BR', 'pt-PT', 'pa-IN', 'ro', 'rm', 'ru', 'sr', 'si', 'sk', 'sl', 'son', 'es-AR', 'es-CL', 'es-MX', 'es-ES', 'sv-SE', 'ta', 'te', 'th', 'tr', 'uk', 'hsb', 'ur', 'uz', 'vi', 'cy', 'xh']
ERROR: Unhandled exception
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/umake/tools.py", line 158, in wrapper
    function(*args, **kwargs)
  File "/usr/lib/python3/dist-packages/umake/frameworks/web.py", line 116, in get_metadata_and_check_license
    UI.delayed_display(TextWithChoices(_("Choose language: {}".format(default_label)), languages, True))
  File "/usr/lib/python3/dist-packages/umake/interactions/__init__.py", line 59, in __init__
    raise BaseException(message)
BaseException: One default was already registered, can't register a second one in that choices set: ['en-US', 'en-US', 'ach', 'af', 'sq', 'ar', 'an', 'hy-AM', 'as', 'ast', 'az', 'eu', 'be', 'bn-BD', 'bn-IN', 'bs', 'br', 'bg', 'my', 'ca', 'zh-CN', 'zh-TW', 'hr', 'cs', 'da', 'nl', 'en-GB', 'en-CA', 'en-ZA', 'en-US', 'eo', 'et', 'fi', 'fr', 'fy-NL', 'ff', 'gd', 'gl', 'ka', 'de', 'el', 'gn', 'gu-IN', 'he', 'hi-IN', 'hu', 'is', 'id', 'ia', 'ga-IE', 'it', 'ja', 'kab', 'kn', 'cak', 'kk', 'km', 'ko', 'lv', 'lij', 'lt', 'dsb', 'mk', 'mai', 'ms', 'ml', 'mr', 'ne-NP', 'nb-NO', 'nn-NO', 'oc', 'or', 'fa', 'pl', 'pt-BR', 'pt-PT', 'pa-IN', 'ro', 'rm', 'ru', 'sr', 'si', 'sk', 'sl', 'son', 'es-AR', 'es-CL', 'es-MX', 'es-ES', 'sv-SE', 'ta', 'te', 'th', 'tr', 'uk', 'hsb', 'ur', 'uz', 'vi', 'cy', 'xh']

В чем здесь проблема и как мне ее решить? Любая помощь ценится. Спасибо

Ответы [ 2 ]

1 голос
/

Официальный репозиторий Ubuntu и репозиторий Ubuntu Desktop содержат версии umake 16.11.1ubuntu1 и 18.05 ~ bionic1 соответственно. Это похоже на ошибку в этих версиях umake. Я установил Umake из репозитория Galileo Sartor и, похоже, все работает нормально под этим Umake. Этот репозиторий содержит версию umake 18.09 + 201902042247 ~ ubuntu18.04.1 во время установки. Именно Umake установил Firefox Developer Edition версии 65.0b5.

  • Удалите ранее установленную Ubuntu make и репозиторий Ubuntu Desktop:

    sudo apt autoremove ubuntu-make
    sudo add-apt-repository --remove ppa:ubuntu-desktop/ubuntu-make
    
  • Чтобы установить Ubuntu, создайте сверху указанный репозиторий и затем firefox-dev:

    sudo add-apt-repository ppa:lyzardking/ubuntu-make
    sudo apt install ubuntu-make
    umake web firefox-dev
    

Этот репозиторий содержит версии ежедневных сборок umake и также упоминается в umake - Ubuntu Wiki , поэтому может рассматриваться как доверенный ppa.

0 голосов
/

umake web firefox-dev --lang en-US

...