Не удается установить Postgresql-10 в Ubuntu 16.04? - proUbuntu
1 голос
/
E: Unable to locate package postgresql-10

Ответы [ 2 ]

7 голосов
/

Я думаю, что репозиторий Postgresql apt не добавлен.

Добавить репозиторий PostgreSQL apt

echo 'deb http://apt.postgresql.org/pub/repos/apt/ xenial-pgdg main' >> /etc/apt/sources.list.d/pgdg.list

Импорт ключа подписи репозитория и обновление списков пакетов

wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -

Установить PostgreSQL

  sudo apt-get update
  sudo apt-get install postgresql-10

исх

1 голос
/

postgresql-10 доступно для Ubuntu 18.04 (т.е. bionic) через стандартные репозитории для установки.

Пожалуйста, обратитесь к https://packages.ubuntu.com/search?keywords=postgresql

...