Установите hdf5 1.8.16 (Xenial) на Bionic (18.04) - proUbuntu
Винтажный Клуб для гитаристов
0 голосов
/

У меня есть приложение, которое было скомпилировано с HDF под Ubuntu 16.04, т.е. hdf5 1.8.16, но мне нужно запустить его на Ubuntu 18.04, то есть hdf5 1.10.

Я пытался создать символические ссылки в / usr / lib / x86_64-linux-gnu с именем "libhdf5_serial.so.10", указывающие на последнюю версию libhdf5_serial.so.100.0.1 под Ubuntu 18.04, но без особого успеха, как я получаю ошибку

HDF5-DIAG: обнаружена ошибка в потоке HDF5 (1.10.0-patch1) 140001026823936: # 000: ../../../src/H5P.c строка 254 в H5Pcreate (): не класс списка свойств Major: неверные аргументы рутины несовершеннолетний: неподходящий тип HDF5-DIAG: обнаружена ошибка в потоке HDF5 (1.10.0-patch1) 140001026823936: # 000: ../../../src/H5Pfapl.c строка 1750 в H5Pset_fclose_degree (): не удается найти объект для идентификатора Major: объектный атом несовершеннолетний: невозможно найти информацию об атоме (уже закрыт?) # 001: ../../../src/H5Pint.c строка 3817 в H5P_object_verify (): список свойств не является членом класса Major: списки недвижимости несовершеннолетний: невозможно зарегистрировать новый атом # 002: ../../../src/H5Pint.c строка 3767 в H5P_isa_class (): не список свойств Major: неверные аргументы рутины несовершеннолетний: неподходящий тип Предупреждение! Ошибка версии библиотеки HDF5 Заголовочные файлы HDF5, используемые для компиляции этого приложения, не совпадают версия, используемая библиотекой HDF5, с которой связано это приложение. Повреждение данных или ошибки сегментации могут произойти, если приложение продолжит работу. Это может произойти, когда приложение было скомпилировано одной версией HDF5, но связаны с другой версией статической или общей библиотеки HDF5. Вы должны перекомпилировать приложение или проверить вашу общую библиотеку, связанную такие настройки, как «LD_LIBRARY_PATH». Вы можете на свой страх и риск отключить это предупреждение, установив среду переменная 'HDF5_DISABLE_VERSION_CHECK' со значением '1'. Установка его на 2 или выше полностью подавит предупреждающие сообщения.

Заголовки 1.8.16, библиотека 1.10.0

что я могу сделать, чтобы решить эту проблему?

Добро пожаловать на сайт proUbuntu, где вы можете задавать вопросы и получать ответы от других членов сообщества.
...