Ошибка apt-get для ядра / dpkg 14.04 LTS - proUbuntu
3 голосов
/

Я использую 14.04 LTS на Dell XPS, и недавно у меня возникли проблемы при использовании apt-get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up oem-audio-hda-daily-lts-xenial-dkms 
(0.201611160201~ubuntu14.04.1) ...
Removing old oem-audio-hda-daily-lts-xenial- 
0.201611160201~ubuntu14.04.1 DKMS files...

------------------------------
Deleting module version: 0.201611160201~ubuntu14.04.1
completely from the DKMS tree.
------------------------------
Done.
Loading new oem-audio-hda-daily-lts-xenial- 
0.201611160201~ubuntu14.04.1 DKMS files...
First Installation: checking all kernels...
Building only for 4.4.0-116-generic
Building for architecture x86_64
Building initial module for 4.4.0-116-generic





Error! Bad return status for module build on kernel: 4.4.0-116-generic (x86_64)
Consult /var/lib/dkms/oem-audio-hda-daily-lts-xenial/0.201611160201~ubuntu14.04.1/build/make.log for more information.
dpkg: error processing package oem-audio-hda-daily-lts-xenial-dkms (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 oem-audio-hda-daily-lts-xenial-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)

В настоящее время я не могу ничего обновить / удалить из-за этого. Я пытался исправить зависимости, но пока не повезло.

1 Ответ

2 голосов
/

После очистки пакета, о котором идет речь, похоже, что оно разрешено:

$ sudo apt-get purge oem-audio-hda-daily-lts-xenial-dkms

Не знаю, почему и как это вообще сломалось.

...