Установите Postgresql-server-dev на RaspberryPi (armhf) под управлением Ubuntu Server 16.04 из исходного кода - proUbuntu
1 голос
/

Я настраиваю свой raspberry pi в качестве тестового сервера для приложения rails. Это требует установки PostgreSQL-server-dev, иначе гем pg не будет установлен с capistrano. Я попытался использовать apt-get и aptitude для установки postgresql-server-dev, однако там написано

 N: Skipping acquire of configured file 'main/binary-armhf/Packages' as repository 'http://apt.postgresql.org/pub/repos/apt xenial-pgdg InRelease' doesn't support architecture 'armhf'

когда я пытаюсь установить. Я добавил репозиторий в pgdg.list, но похоже, что нет порта для архитектуры ARM.

На странице Ubuntu для postgresql под port -> armhf есть страница, но нет ссылки на скачивание, поэтому я считаю, что это невозможно установить с apt-get.

Я нашел ссылку на исходный код здесь Однако я понятия не имею, что делать с этим файлом. Буду признателен за любую помощь в том, как установить или обходные пути.

1 Ответ

0 голосов
/

Неважно, разобрался. wget для загрузки, apt-get для установки зависимостей и dpkg -i для установки самого пакета. Довольно просто.

...