Обновление рубинов - proUbuntu
Купить гитару в Москве
1 голос
/

Я хочу установить ruby ​​gems на мою машину с Linux.

в документации это говорит мне, что нужно набирать эти команды

$ sudo gem install rubygems-update
$ sudo update_rubygems

эта ошибка увеличивается

$ sudo update_rubygems 
Bundler 1.16.0 installed
RubyGems 2.7.3 installed
Regenerating binstubs
`/usr/share/rubygems-integration/all/gems/Ascii85-1.0.2/bin/ascii85` does not exist, maybe `gem pristine Ascii85` will fix it?
`/usr/share/rubygems-integration/all/gems/bettercap-1.6.2/bin/bettercap` does not exist, maybe `gem pristine bettercap` will fix it?
`/usr/share/rubygems-integration/all/gems/bundler-1.15.1/exe/bundle` does not exist, maybe `gem pristine bundler` will fix it?
`/usr/share/rubygems-integration/all/gems/bundler-1.15.1/exe/bundler` does not exist, maybe `gem pristine bundler` will fix it?
`/usr/share/rubygems-integration/2.3.0/gems/byebug-9.1.0/bin/byebug` does not exist, maybe `gem pristine byebug` will fix it?
`/usr/share/rubygems-integration/all/gems/classifier-reborn-2.1.0/bin/bayes.rb` does not exist, maybe `gem pristine classifier-reborn` will fix it?
`/usr/share/rubygems-integration/all/gems/classifier-reborn-2.1.0/bin/summarize.rb` does not exist, maybe `gem pristine classifier-reborn` will fix it?
`/usr/share/rubygems-integration/all/gems/coderay-1.1.2/bin/coderay` does not exist, maybe `gem pristine coderay` will fix it?
`/usr/share/rubygems-integration/all/gems/diff-lcs-1.3/bin/htmldiff` does not exist, maybe `gem pristine diff-lcs` will fix it?
`/usr/share/rubygems-integration/all/gems/diff-lcs-1.3/bin/ldiff` does not exist, maybe `gem pristine diff-lcs` will fix it?
`/usr/share/rubygems-integration/all/gems/domain_name-0.5.20160216/bin/` does not exist, maybe `gem pristine domain_name` will fix it?
`/usr/share/rubygems-integration/all/gems/erubis-2.7.0/bin/erubis` does not exist, maybe `gem pristine erubis` will fix it?
`/usr/share/rubygems-integration/all/gems/geoip-1.4.0/bin/geoip` does not exist, maybe `gem pristine geoip` will fix it?
`/usr/share/rubygems-integration/all/gems/gist-4.6.1/bin/gist-paste` does not exist, maybe `gem pristine gist` will fix it?
`/usr/share/rubygems-integration/all/gems/httpclient-2.8.3/bin/httpclient` does not exist, maybe `gem pristine httpclient` will fix it?
`/usr/share/rubygems-integration/all/gems/jekyll-3.1.6/bin/jekyll` does not exist, maybe `gem pristine jekyll` will fix it?
`/usr/share/rubygems-integration/all/gems/kramdown-1.15.0/bin/kramdown` does not exist, maybe `gem pristine kramdown` will fix it?
`/usr/share/rubygems-integration/all/gems/listen-3.1.5/bin/listen` does not exist, maybe `gem pristine listen` will fix it?
`/usr/share/rubygems-integration/2.3.0/gems/nokogiri-1.8.1/bin/nokogiri` does not exist, maybe `gem pristine nokogiri` will fix it?
`/usr/share/rubygems-integration/all/gems/pdf-reader-1.4.0/bin/pdf_callbacks` does not exist, maybe `gem pristine pdf-reader` will fix it?
`/usr/share/rubygems-integration/all/gems/pdf-reader-1.4.0/bin/pdf_list_callbacks` does not exist, maybe `gem pristine pdf-reader` will fix it?
`/usr/share/rubygems-integration/all/gems/pdf-reader-1.4.0/bin/pdf_object` does not exist, maybe `gem pristine pdf-reader` will fix it?
`/usr/share/rubygems-integration/all/gems/pdf-reader-1.4.0/bin/pdf_text` does not exist, maybe `gem pristine pdf-reader` will fix it?
`/usr/share/rubygems-integration/2.3.0/gems/posix-spawn-0.3.13/bin/posix-spawn-benchmark` does not exist, maybe `gem pristine posix-spawn` will fix it?
`/usr/share/rubygems-integration/all/gems/rack-1.6.4/bin/rackup` does not exist, maybe `gem pristine rack` will fix it?
`/usr/share/rubygems-integration/all/gems/railties-4.2.9/bin/rails` does not exist, maybe `gem pristine railties` will fix it?
`/usr/share/rubygems-integration/all/gems/rake-12.3.0/exe/rake` does not exist, maybe `gem pristine rake` will fix it?
`/usr/share/rubygems-integration/2.3.0/gems/rdiscount-2.1.8/bin/rdiscount` does not exist, maybe `gem pristine rdiscount` will fix it?
`/usr/share/rubygems-integration/2.3.0/gems/redcarpet-3.4.0/bin/redcarpet` does not exist, maybe `gem pristine redcarpet` will fix it?
`/usr/share/rubygems-integration/all/gems/rouge-2.2.1/bin/rougify` does not exist, maybe `gem pristine rouge` will fix it?
`/usr/share/rubygems-integration/all/gems/rubydns-1.0.3/bin/rubydns-check` does not exist, maybe `gem pristine rubydns` will fix it?
`/usr/share/rubygems-integration/all/gems/safe_yaml-1.0.4/bin/safe_yaml` does not exist, maybe `gem pristine safe_yaml` will fix it?
`/usr/share/rubygems-integration/all/gems/sass-3.5.3/bin/sass` does not exist, maybe `gem pristine sass` will fix it?
`/usr/share/rubygems-integration/all/gems/sass-3.5.3/bin/sass-convert` does not exist, maybe `gem pristine sass` will fix it?
`/usr/share/rubygems-integration/all/gems/sass-3.5.3/bin/scss` does not exist, maybe `gem pristine sass` will fix it?
`/usr/share/rubygems-integration/all/gems/sdoc-0.4.1/bin/sdoc` does not exist, maybe `gem pristine sdoc` will fix it?
`/usr/share/rubygems-integration/all/gems/sdoc-0.4.1/bin/sdoc-merge` does not exist, maybe `gem pristine sdoc` will fix it?
`/usr/share/rubygems-integration/all/gems/sequel-4.37.0/bin/sequel` does not exist, maybe `gem pristine sequel` will fix it?
`/usr/share/rubygems-integration/all/gems/spring-1.3.6/bin/spring` does not exist, maybe `gem pristine spring` will fix it?
`/usr/share/rubygems-integration/all/gems/sprockets-3.7.0/bin/sprockets` does not exist, maybe `gem pristine sprockets` will fix it?
`/usr/share/rubygems-integration/all/gems/term-ansicolor-1.3.0/bin/cdiff` does not exist, maybe `gem pristine term-ansicolor` will fix it?
`/usr/share/rubygems-integration/all/gems/term-ansicolor-1.3.0/bin/decolor` does not exist, maybe `gem pristine term-ansicolor` will fix it?
`/usr/share/rubygems-integration/all/gems/term-ansicolor-1.3.0/bin/colortab` does not exist, maybe `gem pristine term-ansicolor` will fix it?
`/usr/share/rubygems-integration/all/gems/term-ansicolor-1.3.0/bin/term_mandel` does not exist, maybe `gem pristine term-ansicolor` will fix it?
`/usr/share/rubygems-integration/all/gems/term-ansicolor-1.3.0/bin/term_display` does not exist, maybe `gem pristine term-ansicolor` will fix it?
`/usr/share/rubygems-integration/2.3.0/gems/thin-1.6.3/bin/thin` does not exist, maybe `gem pristine thin` will fix it?
`/usr/share/rubygems-integration/all/gems/thor-0.19.4/bin/thor` does not exist, maybe `gem pristine thor` will fix it?
`/usr/share/rubygems-integration/all/gems/tilt-2.0.1/bin/tilt` does not exist, maybe `gem pristine tilt` will fix it?
`/usr/share/rubygems-integration/all/gems/treetop-1.6.7/bin/tt` does not exist, maybe `gem pristine treetop` will fix it?

Я просто хочу обновить рубиги не более

1 Ответ

0 голосов
/

Лучшее решение, которое я могу придумать для этого, это собрать из source . Сценарий установки просто необходимо запустить с ruby ./setup.rb, и вы сможете его собрать, установив .gemspec.

Удачи!

Добро пожаловать на сайт proUbuntu, где вы можете задавать вопросы и получать ответы от других членов сообщества.
...