Не удается обновить из-за зависимостей ядра - proUbuntu
3 голосов
/

При попытке обновления появляется следующая ошибка:

The following packages have unmet dependencies :
 linux-image -extra- 3.16.0-73 -generic : Depends : linux-image- 3.16.0-73 -generic but it is not installed
 linux-image -extra- 3.16.0-76 -generic : Depends : linux-image- 3.16.0-76 -generic but it is not is not installed
 linux-image -generic- lts - Utopic : Depends : linux-image- 3.16.0-76 -generic but it is not installed
E : Unmet dependencies . Try to use -f .

Проблема в том, что если я делаю apt-get -f install, я получаю сообщение об ошибке, что на диске недостаточно места. И я проверил это ... в / boot не осталось места.

Так что я погуглил, и все говорят, что мне нужно удалить старые версии ядра, чтобы получить больше места.

Однако я не могу удалить их, потому что тогда я получаю ту же ошибку, что и при попытке обновить свою систему.

Кажется, у меня здесь действительно большая проблема. Кто-нибудь знает, как это решить?

Спасибо.

1 Ответ

2 голосов
/

Попробуйте aptitude в интерактивном режиме (sudo aptitude) или в неинтерактивном режиме (sudo aptitude -f install с последующим sudo aptitude dist-upgrade).

...