как исправить ошибку: конфликт портов: другой экземпляр уже запущен - proUbuntu
0 голосов
/ 19 октября 2015
  • Я запустил две команды

    sudo apt-get update
    sudo apt-get upgrade
    
  • Это даст мне ошибку после обновления (после нажатия "Y")

        Setting up postgresql-9.1 (9.1.19-0ubuntu0.12.04) ...
         * Starting PostgreSQL 9.1 database server                                       
         * Error: Port conflict: another instance is already running on /var/run/postgresql with port 5432
                                                                                 [fail]
        invoke-rc.d: initscript postgresql, action "start" failed.
        dpkg: error processing postgresql-9.1 (--configure):
         subprocess installed post-installation script returned error exit status 1
        Errors were encountered while processing:
         postgresql-9.1
        E: Sub-process /usr/bin/dpkg returned an error code (1)
    
  • Я пробовал столько потоков, но не могу найти решение, помогите

1 Ответ

0 голосов
/ 19 октября 2015

В этом случае уже запущен postgresql. Вам нужно выключить, если выключено:

sudo service postgresql stop

Тогда:

sudo apt-get update
sudo apt-get upgrade

Чтобы убедиться, что ничто не связано с портом 5432, выполните netstat -ntulp|grep 5432.

...