Не удается решить неудовлетворенные зависимости - proUbuntu
2 голосов
/ 14 июня 2015

Я пытаюсь решить мою проблему, и у меня есть некоторые трудности. Я не могу установить / удалить / dist-upgrade / clean / autoclean любой пакет. Когда я пытаюсь запустить sudo apt-get -f install, чтобы исправить неудовлетворенные зависимости, я получаю:

orian@orian-desktop:~$ sudo apt-get -f install
[sudo] password for orian: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
cpp-4.8-arm-linux-gnueabihf cpp-arm-linux-gnueabihf dh-apparmor diffstat
gcc-4.8-arm-linux-gnueabihf-base gettext intltool-debian lib32asan0
lib32atomic1 lib32gcc1 lib32gomp1 lib32itm1 lib32quadmath0 lib32stdc++6
libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
libapt-pkg-perl libarchive-zip-perl libasan0 libasan0-armhf-cross
libasprintf-dev libatomic1 libatomic1-armhf-cross libauthen-sasl-perl
libautodie-perl libbonobo2-common libbonoboui2-common
libc6-armel-armhf-cross libc6-armel-cross libc6-armhf-cross
libc6-dev-armel-armhf-cross libc6-dev-armel-cross libc6-dev-armhf-cross
libclass-accessor-perl libclone-perl libcloog-isl4 libdigest-hmac-perl
libdpkg-perl libemail-valid-perl libfile-fcntllock-perl libfs6
libgcc-4.8-dev libgcc-4.8-dev-armhf-cross libgcc1-armhf-cross
libgettextpo-dev libgettextpo0 libglade2-0 libgnome2-common
libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-common
libgomp1-armhf-cross libio-pty-perl libio-socket-inet6-perl
libio-socket-ssl-perl libio-string-perl libipc-run-perl
libipc-system-simple-perl libisl10 libitm1 liblist-moreutils-perl
libmail-sendmail-perl libmailtools-perl libmpc3 libmpfr4 libnet-dns-perl
libnet-domain-tld-perl libnet-ip-perl libnet-libidn-perl
libnet-smtp-ssl-perl libnet-ssleay-perl liborbit-2-0
libparse-debianchangelog-perl libperlio-gzip-perl libquadmath0
libsfasan0-armhf-cross libsfatomic1-armhf-cross libsfgcc-4.8-dev-armhf-cross
libsfgcc1-armhf-cross libsfgomp1-armhf-cross libsfstdc++-4.8-dev-armhf-cross
libsfstdc++6-armhf-cross libsocket6-perl libstdc++-4.8-dev
libstdc++-4.8-dev-armhf-cross libstdc++6-armhf-cross libsub-identify-perl
libsub-name-perl libsys-hostname-long-perl libtext-levenshtein-perl
libtimedate-perl libtsan0 liburi-perl linux-headers-3.16.0-30
linux-headers-3.16.0-30-generic linux-image-3.16.0-30-generic
linux-image-extra-3.16.0-30-generic linux-libc-dev-armel-cross
linux-libc-dev-armhf-cross patchutils po-debconf t1utils x11-xfs-utils xinit
xorg-docs-core
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libc6-dev-amd64:i386
The following NEW packages will be installed:
libc6-dev-amd64:i386
0 upgraded, 1 newly installed, 0 to remove and 9 not upgraded.
16 not fully installed or removed.
Need to get 0 B/1,429 kB of archives.
After this operation, 9,590 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 244830 files and directories currently installed.)
Preparing to unpack .../libc6-dev-amd64_2.19-0ubuntu6.6_i386.deb ...
Unpacking libc6-dev-amd64 (2.19-0ubuntu6.6) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-dev-amd64_2.19-0ubuntu6.6_i386.deb (--unpack):
trying to overwrite '/usr/include/gnu', which is also in package libc6-dev-i386 2.19-0ubuntu6.6
Errors were encountered while processing:
/var/cache/apt/archives/libc6-dev-amd64_2.19-0ubuntu6.6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Я пробовал это Как разрешить неудовлетворенные зависимости после добавления PPA? , но я получаю ту же ошибку Помогите мне, пожалуйста. Большое спасибо, Ориан.

EDIT: Когда я пытаюсь запустить sudo apt-get autoremove, я получаю:

orian@orian-desktop:/boot$ sudo apt-get autoremove
[sudo] password for orian: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
gcc-4.8-multilib:i386 : Depends: libc6-dev-amd64:i386 (>= 2.11) but it is not installed
libc6-dev-x32:i386 : Depends: libc6-dev-amd64:i386 (= 2.19-0ubuntu6.6) but it is not installed
E: Unmet dependencies. Try using -f.

и для uname -mr:

orian@orian-desktop:/boot$ uname -mr
3.16.0-39-generic x86_64

1 Ответ

4 голосов
/ 14 июня 2015

Я думаю, что вы затронуты уже сообщенной ошибкой в ​​libc6-dev. Похоже, что никаких исправлений не предусмотрено, но один обходной путь (предоставленный в комментарии № 4 и, возможно, № 5) - полностью удалить этот пакет:

sudo apt-get purge libc6-dev-amd64
sudo apt-get autoremove
sudo apt-get clean
sudo apt-get install -f

Вы также можете увидеть sudo apt-get -f установка не удалась post

...