Ubuntu 14.04 с ядром 3.19 хочет обновить до 3.16 - proUbuntu
4 голосов
/ 14 июня 2015

Я недавно обновил свое ядро ​​до 3.19.0 для решения некоторых проблем с Dell XPS 9394 ('15), и в основном все работает хорошо, хотя теперь обновление программного обеспечения выглядит так, как будто оно хочет загрузить и установить заголовки и образы для ядра 3,16. Как мне убедиться, что SU тянет обновления для ядра 3.19?

Заранее спасибо!

1 Ответ

4 голосов
/ 14 июня 2015

обо всем по порядку. Как вы установили ядро ​​3.19? Поскольку вы работаете с выпуском LTS, рекомендуемый способ установки новых ядер - Hardware Enablement . Ядро 3.19 доступно в репозиториях Ubuntu 14.04. Убедитесь, что он установлен:

sudo apt-get install linux-generic-lts-vivid

Теперь перезагрузите компьютер, чтобы загрузить новое ядро. Убедитесь, что он работает:

uname -r

Приведенная выше команда должна возвращать что-то вроде 3.19.0-20-generic. Теперь вы можете удалить старые ядра. Начните с:

sudo apt-get purge linux-generic linux-image-generic linux-headers-generic linux-generic-lts-utopic linux-headers-generic-lts-utopic linux-image-generic-lts-utopic linux-signed-generic linux-signed-generic-lts-utopic

Вышесказанное должно удалить метапакеты ядра, которые устанавливают обновления для ядер 3.13 и 3.16. На данный момент более новые выпуски для ядер 3.13 и 3.16 больше не будут предлагаться, но (возможно) уже установленные ядра могут получать обновления. Список установленных пакетов ядра:

dpkg -l | grep -E "linux-(generic|headers|image|signed)" | colrm 80

Если вы видите какой-либо пакет с версией ниже 3.19, удалите его:

sudo apt-get purge <package name 1> <package name 2> ...
...