Установка 32-битного приложения на 64-битной Ubuntu 15.10 - proUbuntu
Винтажный Клуб для гитаристов
0 голосов
/

Я пытался установить 32-битное приложение Linux (Cadsoft Eagle) на 64-битную Ubuntu 15.10 через терминал. Это был результат:

error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

Я уже установил много библиотек для поддержки 32 бит.

Когда я пытаюсь установить этот пакет (sudo apt-get install libssl0.9.8:i386), получается:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libssl0.9.8:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libssl0.9.8:i386' has no installation candidate

Что я могу сделать?

1 Ответ

1 голос
/

libssl0.9.8 больше не доступен в репозиториях Ubuntu 15.10. Вы можете загрузить и установить файл deb вручную по этой ссылке, если хотите libssl0.9.8 (перейдите по ссылке "security.ubuntu.com/ubuntu", когда перейдете на эту страницу).

вы можете установить загруженный пакет, скопировав файл deb в вашу домашнюю папку, затем открыть терминал и ввести эту команду sudo dpkg -i libssl0.9.8_0.9.8o-7ubuntu3.2_amd64.deb

Добро пожаловать на сайт proUbuntu, где вы можете задавать вопросы и получать ответы от других членов сообщества.
...