Как включить пакеты из старых выпусков Ubuntu? - proUbuntu
Купить гитару в Москве
0 голосов
/

Я хочу включить MSN с сопереживанием (как вы можете видеть на моем другом вопросе Подключение Empathy к Windows Live ), но у меня всегда возникают проблемы с зависимостями при установке пакетов. Например, я хочу установить пакет telepathy-haze, но это зависит от пакета libpurple0. Хорошо, но когда я пытаюсь sudo apt-get install libpurple0, он говорит, что получил неудовлетворенные зависимости: это зависит от libgstfarsight0.10-0 (>= 0.0.3), libperl5.12 (>= 5.12.4) и perlapi-5.12.4, все они не могут быть установлены. Когда я ищу эти пакеты в http://packages.ubuntu.com,, я могу найти их только как пакеты Oneiric, а не как Precise. Как я могу установить пакеты из более старых выпусков, таких как Oneiric, и решить эту проблему?

1 Ответ

0 голосов
/

Загрузите все нужные вам дэбы и используйте dpkg для установки файлов один за другим.

dpkg не проверяет зависимости, поэтому вы можете подключить свою систему, поэтому тщательно спланируйте ее.

edit: похоже, что libgstfarsight заменено пакетом farstream

Так что вам нужно установить libgstfarsight0.10-0 (> = 0.0.3), libperl5.12 (> = 5.12.4) и perlapi-5.12.4 с dpkg, и тогда вы сможете установить telepathy дымка (libpurple установится сам)

Другой вариант:

Тарбол с исходным кодом можно найти здесь с последней версией, созданной 2012.04 (поэтому она очень свежая): http://telepathy.freedesktop.org/releases/telepathy-haze/

Похоже, что это зависит от телепатии ≥ 0.13.9 и libpurple ≥ 2.7.0.

Добро пожаловать на сайт proUbuntu, где вы можете задавать вопросы и получать ответы от других членов сообщества.
...