Как навсегда удалить эти сообщения об ошибках при использовании Openbox GNOME? - proUbuntu
Купить гитару в Москве
1 голос
/

Как навсегда удалить эти сообщения об ошибках при использовании Openbox GNOME? Например: обновить последнюю версию Ubuntu, ошибки такого рода и т. Д., Как навсегда отключить их, чтобы они не отображались перед моей презентацией.

enter image description here

Продолжение:

а) Как убить окно с ошибкой снимка экрана?

$ cat /etc/default/whoopsie

[General]
report_crashes=false

$ apport-cli

*** Send problem report to the developers?

After the problem report has been sent, please fill out the form in the
automatically opened web browser.

What would you like to do? Your options are:
  S: Send report (69.7 KB)
  V: View report
  K: Keep report file for sending later or copying to somewhere else
  I: Cancel and ignore future crashes of this program version
  C: Cancel
Please choose (S/V/K/I/C): I

б) Как убить диалоговое окно уведомления об обновлении?

$/etc/xdg/autostart# vim update-notifier.desktop 
#NoDisplay=true
NoDisplay=false
:wq

$ cat update-notifier.desktop | grep NoDisplay
NoDisplay=false

Теперь больше нет тревожных всплывающих окон.

Окончательное наблюдение:

root@sun-Inspiron-One-2320:~# apt-get -f remove apport update-manager update-manager-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 apport-gtk : Depends: apport (>= 0.41) but it is not going to be installed
 opera:i386 : Depends: libc6:i386 (>= 2.3.2) but it is not going to be installed
              Depends: libc6:i386 (>= 2.3.6-6~) but it is not going to be installed
              Depends: libfontconfig1:i386 but it is not going to be installed
              Depends: libfreetype6:i386 (>= 2.2.1) but it is not going to be installed
              Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
              Depends: libglib2.0-0:i386 (>= 2.16.0) but it is not going to be installed
              Depends: libgstreamer-plugins-base0.10-0:i386 (>= 0.10.16) but it is not going to be installed
              Depends: libgstreamer0.10-0:i386 (>= 0.10.15) but it is not going to be installed
              Depends: libice6:i386 but it is not going to be installed
              Depends: libsm6:i386 but it is not going to be installed
              Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed
              Depends: libx11-6:i386 but it is not going to be installed
              Depends: libxext6:i386 but it is not going to be installed
              Depends: libxml2:i386 (>= 2.6.27) but it is not going to be installed
              Depends: libxrender1:i386 but it is not going to be installed
              Depends: libxt6:i386 but it is not going to be installed
              Depends: zlib1g:i386 (>= 1:1.1.4) but it is not going to be installed
              Depends: gstreamer0.10-plugins-good:i386 but it is not going to be installed
              Depends: fonts-liberation:i386 but it is not installable or
                       ttf-liberation:i386 but it is not installable or
                       ttf-mscorefonts-installer:i386 but it is not installable
              Recommends: flashplugin-nonfree:i386
              Recommends: cups-client:i386 but it is not going to be installed
 update-notifier : Depends: update-manager-gnome but it is not installable or
                            update-manager but it is not going to be installed
 xdiagnose : Depends: apport but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Ответы [ 2 ]

2 голосов
/

Вышеприведенная ошибка, вероятно, связана с whoopsie, демоном отчета о сбое. Вы можете отключить его, отредактировав /etc/default/whoopsie и изменив report_crashes=true на false. Что касается обновлений, лучшим решением, IMHO, было бы их установить, однако, если это невозможно, отключите проверку обновлений и средство уведомления об обновлениях.

Какие еще ошибки вы получаете?

0 голосов
/

Для первого диалога попробуйте удалить apport. Во-вторых, вы можете удалить update-manager и update-manager-core, предполагая, что @ mikewhwhat имеет правильные имена пакетов (в настоящее время я не на машине с Ubuntu).

Вы можете сделать это следующим образом:

sudo apt-get remove apport update-manager update-manager-core

Я довольно уверен в apport, потому что это программа, которая обрабатывает автоматические сообщения об ошибках. Вместо того, чтобы разбираться с конфигурацией, просто избавьтесь от нее, поскольку она вам не нравится.

Добро пожаловать на сайт proUbuntu, где вы можете задавать вопросы и получать ответы от других членов сообщества.
...